Without being there in the kitchen with you, it’s difficult to say what the issue was; however, I can definitely help you troubleshoot…did you cook it for the full amount of time the recipe calls for, and did you cover the top with foil for the last 15 minutes? If so, there might be an issue with your oven’s calibration (you can get an inexpensive oven thermometer to check this). Another tip is to let your eggs come to room temperature first. Another factor is the altitude at which you’re baking; if you’re at high altitude, you might need to slightly adjust the oven temperature and bake time. The other thing to remember is that there will usually be a little bit of fall to most keto breads (in fact, every keto bread we’ve ever made) because keto flours lack gluten and are naturally quite dense; however, you can see in the photos, we still got a fairly good rise on this loaf. I hope these tips help!
I followed the recipe to a tee, used all recommended ingredients. I’ve attempted making it twice, the first time I didn’t have a food processor and that was a complete fail. The second time, today, I bought a food processor and attempted it again. The egg whites were fluffy but never got to stiff peaks… maybe my eggs were too cold? Anyway, I baked for 30 mins, and it wasn’t even golden brown on the top so I didn’t put the foil on time and cooked it another 20 mins. I just pulled it out about 20 mins ago and it is golden brown. However, it is a very moist almost like a banana bread texture. I just popped it back in the oven hoping it will “dry up”. Any recommendations? Do I need to cook for and hour ?
×